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Field Pro product registration says "We couldn't verify this address"

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Field Pro product registration says "We couldn't verify this address"
Field-Pro-product-registration-says-We-couldn-t-verify-this-address
Content

Product Registration displays “We couldn’t verify this address”

Environment

This issue may occur when attempting to register a generator in the Field Pro mobile app.

Issue

During product registration, the address validation service may display “We couldn’t verify this address.”

Cause

In limited scenarios, it is possible that the address validation service used during product registration does not have a matching address. For example, new development areas may not be USPS-recognized addresses yet.

Resolution

  1. Contact Generac Customer Support at 1-888-922-8482 for assistance. Generac Customer Support will need to complete the registration on your behalf.
  2. After Generac Customer Support confirms the registration has been completed, navigate back to the “Registration is required” screen and select Recheck registration status.
Note: It may take a few minutes for the systems to sync once registration has been completed.

 

 


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