Troubleshooting the No/Bad SSID Wi-Fi connection error
When attempting to connect a Guardian Series generator equipped with a Mobile Link Onboard Wi-Fi device, the controller panel may display a "No/Bad SSID" error at the end of setup. This indicates that the device was unable to fully connect to the router.
Environment
This article applies to:
- Guardian Series generators with the Onboard Wi-Fi Mobile Link Connectivity Device.
Note: For help identifying a Mobile Link Connectivity Device, see: Mobile Link Wi-Fi, Cellular, and LTE device compatibility guide
Probable cause
The router did not allow the Mobile Link device to fully connect. The router may be blocking the device or have settings that prevent a successful connection.
Recommended action
1. Confirm that the Wi-Fi network is compatible with the Mobile Link device by referencing the guide: Is My Wi-Fi Network Compatible With Mobile Link?
2. Power cycle your router
3. Retry the Wi-Fi connection process after verifying network compatibility.
Reset the Mobile Link device
If the device still cannot fully connect after confirming network compatibility and retrying, performing a hard reset of the Mobile Link accessory is recommended before attempting the connection again. Refer to the support article: How do I hard reset or power cycle a Mobile Link device?
Use a Wi-Fi range extender
Struggling to connect or stay connected?
Upgrading to the Connectivity Cellular Accessory is recommended for users who wish to add connectivity to their generator OR for users experiencing ongoing connectivity issues. It is compatible with more generators, and uses multiple carrier networks to offer greater coverage. Basic (free) and Premium cellular plans are available for users of this device. See here to upgrade: Connectivity Cellular Accessory.